This project is read-only.

reset debug enviroinment

Topics: General
Apr 8, 2014 at 7:23 AM
Edited Apr 8, 2014 at 10:28 PM

Is there soms way to reset the debug environment? I kinda broke it, only getting plain white text in a c# code file of a console app.

Tried to remove that extra folder that was created in the root of my solution, but that didn't do the trick. Tried to compile with just return on top of my analyze function too see if my code broke it, but that gives the same result.

Currently getting the following error: Project 'ConsoleApplication1' could not be opened because the Visual C# 2013 compiler could not be created. Package 'CSharpPackage' failed to load.

Any tips?


May 13, 2014 at 5:13 PM

Did you figure this out? I installed Update 2 to Visual Studio and I am getting the same error.

Aaron K. Clark
May 14, 2014 at 6:27 AM
Edited May 14, 2014 at 6:31 AM
Hi Aaron,

Not sure, I ended up just installing a fresh machine.

I assume it has something to do with the folder: C:\users\<username>\AppData\Local\Microsoft\VisualStudio\12.0Roslyn
You can startup the Roslyn dev environment, by running devenv /RootSuffix Roslyn

I think you need to do the following:
  • uninstall Roslyn extensions
  • delete everything that is left of roslyn
    • delete the 12.0Roslyn folder in C:\users\<username>\AppData\Local\Microsoft\VisualStudio
    • In regedit delete HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\12.0Roslyn and HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\12.0RoslynConfig
  • run the "Install Roslyn Preview into Roslyn Experimental Hive.exe" to recreate the 12.0Roslyn folder.
  • reinstall Roslyn extensions
I probably deleted more files which broke other stuff in VS, so needed a reinstall.

Gr, Erik
Apr 18, 2015 at 7:47 PM
Hi there,

Sorry to bring this post back from the dead but according to the New Roslyn Project Site - "Roslyn is no longer available for Visual Studio 2013."

(Was following instructions to test out Code Connect (Alpha) but I had the same "Visual C# 2013 compiler could not be created" problem).

Thanks for the instructions for uninstalling Roslyn clean from VS2013.

Cheers, Wyco