Awful translation into OS language in IntelliSense

Topics: General
Sep 18, 2014 at 11:08 AM
Edited Sep 18, 2014 at 1:24 PM
I actually posted this question to connect.microsoft.com, but no answer was given, so I decided to post a message here.
I use Visual Studio 2014 CTP3 with English UI (no other language was installed), but that issue appeared after installing Roslyn Preview for VS 2013. The problem is that IntelliSense shows pop-ups in language of OS. In my case, it's Russian language. What for? Moreover, the translation leaves much to be desired. It is very awful. There can be intermixing of Russian and English words.
Let's take some example.
Image
On picture, you see the description of Application.Run method overload.

__"Запускает а WPF приложение и открытие указанное окно".
"window: A Window то открывается автоматически при запуске приложения".__

Really? Which translator did you, guys, use? Google?
What I want is to give a user ability to select a language for IntelliSense. Please, make it an option.
Developer
Sep 18, 2014 at 6:11 PM
Localization has not been finished for Visual Studio '14', thanks for filing a bug on connect. We'll make sure to test this scenario when the translations are done. In the future you can also file an issue on this codeplex site.

One thing I am curious about: if I am reading you correctly, you installed Visual Studio '14' CTP3 with the Roslyn Preview for VS 2013? Roslyn is already included with Visual Studio '14' CTP3, there should be no need to install the Roslyn Preview for VS 2013.
Sep 19, 2014 at 4:14 AM
Edited Sep 19, 2014 at 4:48 AM
The screenshot in the first message is from VS 2013 Express Update 3 (with Roslyn), but the same thing is in VS 2014. I always thought that if UI is English, then all messages must be in English too. So, I expect English IntelliSense in English UI and Russian IntelliSense in Russian UI. At least, let user choose the language for IntelliSense. The reason is simple - always incorrect translation. As a bright example, let me point to splendid application - Excel. When you right-click on the sheet's tab, I see "View Code" button. Reading this, I understand that I am about to watch CODE. But! In Russian UI you, guys, wrote "Исходный текст" - in English it will be "Source TEXT". Really? Text? Which text? This is highly non-intuitive! That's why I don't use Russian translation in all programs, not just of Microsoft. So, please, let user select the language for IntelliSense.

P.S. This is not the only place with incorrect translation.
Coordinator
Sep 25, 2014 at 4:25 AM
You can change the VS language in Tools\Options\Environment, and this should affect the XML doc comments shown in IntelliSense.
Sep 25, 2014 at 9:23 AM
Yes, "should", but doesn't. I have "English" in International Settings, but IntelliSense is still in Russian language.